WordPressをアップデートした

このブログはずっとほっぽりっぱなしだったので、Wordpressのバージョンも上げていませんでした。今度書こうと思いますが、O’Reillyの本やビデオのレビューを書くことでただで電子書籍(英語版ですが)を入手することができるということで、このブログを利用して書くことにしました。

というわけでさすがに2.2.3(だったかな?)はまずいだろう、ということでアップデート。というか古すぎてアップデートするのも怖かったので、いったん別ドメインで新規インストール後、旧サイトでエクスポートしたものをインポートしました。

ちなみにインポート時に

"This does not appear to be a WXR file, missing/invalid WXR version number"

というエラーがでました。
Importing from very old WP (2.2.3) to newest version をみるとどうやらエクスポートファイルにバージョン名の指定がないのが問題の様子。

<channel>タグの下に

<wp:wxr_version>1.1</wp:wxr_version>

を追加することで解決しました。

テーマはデフォルトのが意外にもいい感じだったので、それを使うことにしました。